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INTRODUCTION 
In accordance with “Task 4 Data Collection and Analysis”, the Report represents results 
and analysis for data collection from diverse stakeholder groups focusing on renewable 
energy planning and addressing key issues such as policy priorities, feasibility, and 
barriers in five regions/oblasts in Ukraine (Lviv, Zakarpattia, IvanoFrankivsk, Chernivtsi, 
and Vinnytsia).  
 
Collected data will be used for: RAAs spatial planning process (RE potential and 
infrastructure readiness); technical analysis of renewable energy potential and 
infrastructure readiness, evaluating capacity, feasibility, and alignment with RES targets; 
preliminary economic analysis on the feasibility of renewable energy projects in RAAs. 
 
The information obtained within the scope of the Project will not be utilized by specialist 
for any commercial purposes and is intended for open-source sharing. Upon request 
from stakeholders who hold relevant information and data, a Non-Disclosure Agreement 
(NDA) can be signed to provide reassurance regarding confidentiality in line with the 
internal rules of the Energy Community Secretariat. 
 
The Report contains two sections: Section 1.  Results of data collection regarding 
renewable energy planning and  Section  2. Apply methods for the analysis and 
processing of geospatial layers.  
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1. RESULTS OF DATA COLLECTION REGARDING RENEWABLE ENERGY 
PLANNING 
 

1.1. Source of data collection 
 

Collected data Data sources Data 
format

s 

Coord
inate 
syste
ms 

Resol
ution 

Metadat
a 

Criterion: Artificial and built surfaces 
Geospatial data in 
vector format on 
the location and 
footprints of 
buildings. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map ) and META AI Building 
Footprints 
(https://github.com/microsoft/Global
MLBuildingFootprints)  

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
transport 
infrastructure. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
parking areas. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
farms. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
waste sites. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
industrial sites. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
mines and 
quarries. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in 
vector format on 
the location of 
artificial water 
bodies. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Geospatial data in OpenStreetMap (OSM) collaborative GeoPac WGS-  Not    

https://www.openstreetmap.org/export#map
https://www.openstreetmap.org/export#map
https://github.com/microsoft/GlobalMLBuildingFootprints
https://github.com/microsoft/GlobalMLBuildingFootprints


 

3 
Implemented by the Energy Community Secretariat 

vector format on 
the location of 
wastewater 
treatment sites. 

database 
(https://www.openstreetmap.org/ex
port#map) 

kage 
(.gpkg) 

84 applic
able 

Available 

Geospatial data in 
vector format on 
the location of the 
power grid. 

OpenStreetMap (OSM) collaborative 
database 
(https://www.openstreetmap.org/ex
port#map) 

GeoPac
kage 
(.gpkg) 

WGS-
84 

 Not 
applic
able 

   
Available 

Criterion: Solar Potential 
Raster data on 
Global Horizontal 
Irradiation (GHI). 

Global Solar Atlas, provided by 
Solargis for The World Bank 
(https://globalsolaratlas.info/downlo
ad/ukraine)  

GeoTIF
F 

WGS-
84 

Gridd
ed 
data 
(~250 
m) 

   
Available 

Criterion: Wind Potential 
Raster data on 
mean wind speed 
at 100m height. 

Global Wind Atlas, provided by the 
Technical University of Denmark 
(DTU) for The World Bank Group 
(https://globalwindatlas.info/en/area
/Ukraine)  

GeoTIF
F 

WGS-
84 

Gridd
ed 
data 
(~250 
m) 

   
Available 

Criterion: Elevation and Steep slopes 
Digital Elevation 
Model (Digital 
Surface Model). 

Copernicus DEM (GLO-30), derived 
from TanDEM-X mission data. 
Provided by the Copernicus 
Programme of the European Union 
(https://portal.opentopography.org/r
aster?opentopoID=OTSDEM.032021.
4326.3)  
(https://dataspace.copernicus.eu/ex
plore-data/data-
collections/copernicus-contributing-
missions/collections-
description/COP-
DEM#:~:text=The%20Copernicus%20
DEM%20is%20a%20Digital%20Surfac
e%20Model,through%20the%20TanD
EM-
X%20mission%20between%202011%
20and%202015.)  

GeoTIF
F 

WGS-
84 

30 m    
Available 

Criterion: Land Use / Land Cover 
Global estimates of 
land use/land 
cover (LULC). 

Esri and Impact Observatory, derived 
from Sentinel-2 imagery 
(https://livingatlas.arcgis.com/landc
over/)  

GeoTIF
F 

WGS-
84 

10 m Available 

 
2. APPLIED METHODS FOR THE ANALYSIS AND PROCESSING OF 

GEOSPATIAL LAYERS 
 
This chapter presents a detailed methodology for the creation and processing of 

https://globalsolaratlas.info/download/ukraine
https://globalsolaratlas.info/download/ukraine
https://globalwindatlas.info/en/area/Ukraine
https://globalwindatlas.info/en/area/Ukraine
https://portal.opentopography.org/raster?opentopoID=OTSDEM.032021.4326.3
https://portal.opentopography.org/raster?opentopoID=OTSDEM.032021.4326.3
https://portal.opentopography.org/raster?opentopoID=OTSDEM.032021.4326.3
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://dataspace.copernicus.eu/explore-data/data-collections/copernicus-contributing-missions/collections-description/COP-DEM#:%7E:text=The%20Copernicus%20DEM%20is%20a%20Digital%20Surface%20Model,through%20the%20TanDEM-X%20mission%20between%202011%20and%202015
https://livingatlas.arcgis.com/landcover/
https://livingatlas.arcgis.com/landcover/
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geospatial layers to identify potential Renewable Energy Acceleration Areas (RAA) in 
Ukraine. All operations are performed in the QGIS environment, adhering to unified 
technical standards: GeoPackage (.gpkg) format and the WGS-84 (EPSG:4326) 
coordinate system.  
 

2.1. Rooftops_and_Facades_of_Buildings 
 

This layer identifies rooftops and facades of buildings suitable for the installation of 
solar photovoltaic panels. 
 
2.1.1.Data sources from OpenStreetMap (OSM) and other open sources. 
 

Category OSM (key=value) Description 
Residential 
Buildings 

building=apartments A multi-story residential building 
with several separate 
apartments.  

building=bungalow A single-story residential 
building.  

building=detached A stand-alone house not 
connected to other buildings.  

building=dormitory A building with rooms for 
students or workers to live in.  

building=house A private house for a single 
family.  

building=residential A general-purpose residential 
building.  

building=semidetached_house A house that shares one 
common wall with an adjacent 
house. 

Commercial 
Buildings 

building=commercial A building used for commercial 
activities.  

building=industrial An industrial building for 
manufacturing.  

building=office A building with office spaces.  
building=retail A building for retail trade.  
building=supermarket A large self-service retail 

building.  
building=warehouse A commercial building for 

storing goods. 
Civic/Amenity 
Buildings 

building=civic A public building for civic 
purposes (   community 
centers).  

building=government A building for government 
institutions.  

building=hospital A hospital for medical services.  
building=kindergarten A building for preschool 

education.  
building=school A building for general education.  
building=train_station A railway station building. 
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building=university A university building.  
building=public A public building (town hall, 

police, courthouse). 
Other Sources META AI Building Footprints A global dataset of building 

footprints identified using AI. 
 
2.1.2. Detailed Processing Methodology in QGIS: 
 
Creating the Base Layer: 
Data Import: Using the QuickOSM plugin, all objects with the building key are 
downloaded. The META AI Building Footprints layer is added to the project separately. 
Merge: The OSM and META layers are combined using the "Merge vector layers" tool 
(Processing Toolbox -> Vector general -> Merge vector layers). 
Cleaning: To eliminate duplicates and overlaps, the "Dissolve" tool is applied (Vector -> 
Geoprocessing Tools -> Dissolve). Topological correctness is ensured with the "Fix 
geometries" tool (Processing Toolbox -> Vector geometry -> Fix geometries). The result 
is saved as Buildings_Base. 
1. Filtering by Technical Suitability Criteria: 
GHI ≥ 1100 kWh/m²: The Global Horizontal Irradiation raster layer from the Global Solar 
Atlas is downloaded. Using "Zonal Statistics" (Processing Toolbox -> Raster analysis -> 
Zonal Statistics), the average GHI value is calculated for each building. Objects with GHI 
< 1100 are filtered out.    
Area: The area of each building is calculated in the "Field Calculator" ($area). Objects 
with an area insufficient for effective installation ( < 100 m²) are filtered out. 
Grid Availability (≤ 5 km): The power grid layer is downloaded from OSM (power=line, 
power=substation). The "Distance to nearest hub" tool (Processing Toolbox -> Vector 
analysis -> Distance to nearest hub) is used to calculate the distance to the grid. 
Buildings farther than 5 km are filtered out. 
2. Filtering by Legal Constraints: 
Exclusion of Cultural Heritage Sites: The official layer of cultural heritage sites is loaded. 
Using the "Difference" tool (Vector -> Geoprocessing Tools -> Difference), these areas 
are cut out from the layer of potential buildings. 
4. To determine the orientation of buildings relative to the cardinal directions, the 
"Oriented minimum bounding box" tool from the Processing Toolbox (Vector geometry 
- Oriented minimum bounding box) was used. This tool created an oriented bounding 
rectangle for each building with an "angle" field, which contains the rotation angle of the 
building's main axis relative to the north direction.    
The input layer was the "Buildings" layer, and the result was saved as 
"Buildings_oriented_bbox". The resulting angle was then transferred to the original 
buildings layer using the "Join attributes by location" tool. After the join, azimuth 
normalization was performed in the Field Calculator to adjust the values to a 0-360 
degree range. To determine the building's suitability based on the orientation criterion 
(south, southeast, southwest – a range of 135-225 degrees), a conditional CASE 
expression was used. 
5. Verification: Verification of the collected data will be carried out in the following steps: 
cross-comparison of information from open sources to identify discrepancies in the 
spatial location and classification of objects; topological control (verification of the 
correctness of connections between lines and nodes of the network). 
6. Final result: A polygonal layer Rooftops_and_Facades_of_Buildings, containing 
buildings that have passed all filtering stages. 
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2.2. Transport_Infrastructure_Corridor 
 
This layer identifies roadside adjacent territories suitable for the installation of solar 
panels. For the analysis of transport corridors, a linear vector layer of highways 
(highway) from the OpenStreetMap database was used. This layer serves as the primary 
source for identifying any type of roads, streets, or pathways. The transport 
infrastructure includes land within the right-of-way boundaries (excluding the roadway 
directly intended for vehicle movement and shoulders), as well as land outside the right-
of-way if it contains facilities that ensure the functioning of highways (such as parking 
and rest areas) in relation to roads of national importance. 
 
2.2.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Roads highway=motorway A high-class road with controlled access.  

highway=trunk A road of international and national importance.  
highway=primary A road of regional importance.  
highway=secondary A road of oblast-level importance. 

 highway=service  A service road that provides access to specific 
facilities, such as industrial sites, parking areas, 
buildings, or other infrastructure objects 

 
2.2.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer: 
Data Import: Linear objects of roads are downloaded using QuickOSM. 
Corridor Creation: Using the "Buffer" tool (Vector -> Geoprocessing Tools -> Buffer), a 
polygonal zone 20 meters wide is created on both sides of the linear features, with the 
"Dissolve result" option enabled. 
2. Filtering by Technical Suitability Criteria: 
Buildings with Global Horizontal Irradiation (GHI) ≥ 1100 kWh/m² were retained. The 
same methodology as described in Group 1 was applied. 
Exclusion of Slopes > 15° and Altitudes > 1900 m: 
The Copernicus DEM (GLO-30) digital elevation model is loaded.    
A slope layer is calculated using the "Slope" tool (Raster -> Analysis -> Slope). 
A binary raster of suitable areas is created in the "Raster Calculator" (("Slope@1" <= 15) 
AND ("Copernicus_DEM@1" <= 1900)). 
The raster is converted to a vector (Raster -> Conversion -> Polygonize). 
Using the "Intersection" tool (Vector -> Geoprocessing Tools -> Intersection), only the 
parts of the corridor that meet the criteria are retained.Grid Availability (≤ 30 km): 
Distance analysis to the power grid is applied with a 30 km threshold. 
3. Verification: Verification of the collected data will be carried out in the following 
steps: cross-comparison of information from open sources to identify discrepancies in 
the spatial location and classification of objects; topological control (verification of the 
correctness of connections between lines and nodes of the network). 
Final result: Polygon layer Transport_Infrastructure_Corridor. 
 

2.2. Parking_Areas 
 
This layer identifies open parking lots suitable for the installation of solar canopies. 
2.3.1. Data sources from OpenStreetMap (OSM): 
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Category OSM (key=value) Description 
Parking Lots amenity=parking A general-purpose parking area.  

parking=surface An open, surface-level parking lot. 
Related 
Areas 

landuse=retail Retail land use areas (often with large 
parking lots).  

landuse=commercial Commercial zones. 
 parking=multi-storey  multi-storey car park; 
 parking=underground underground parking 
 amenity=parking_space single parking space for one vehicle 

 
2.3.2. Detailed Processing Methodology in QGIS: 
1.  Creating the Base Layer (Parking_Base) 
Importing Data from OSM: 
Tool: QuickOSM Plugin. Action: A query is created to extract all polygonal features with 
the tag amenity = parking within the study area. This provides an initial dataset including 
all types of parking facilities. Filtering for Suitable Parking Types: Tool: "Select by 
expression". 
Action: From the initial layer, it is necessary to exclude features that are not open, 
surface-level parking lots. An expression is applied to filter out multi-story and 
underground parking: "parking" NOT IN ('multi-storey', 'underground') OR "parking" IS 
NULL. The IS NULL condition is important as many surface parking lots are tagged only 
with amenity=parking without additional specifiers. 
Result: The selected features are saved into a new layer named Parking_Base. 
Verifying and Fixing Geometry 
Tool: "Fix geometries" (Processing Toolbox -> Vector geometry -> Fix geometries). 
Action: This tool is applied to the Parking_Base layer to correct any topological errors 
(self-intersections), ensuring the validity of subsequent overlay analysis operations. 
2. Filtering by Technical Suitability Criteria 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Data Source: GHI raster layer from the Global Solar Atlas. 
Tool: "Zonal Statistics" (Processing Toolbox -> Raster analysis -> Zonal Statistics). 
Action: The average GHI value is calculated for each polygon in the Parking_Base layer. 
The result is written to a new field (GHI_mean). Filtering: Using "Select by expression", 
features that satisfy the condition "GHI_mean" >= 1100 are selected. 
Area Analysis 
Tool: "Field Calculator". 
Action: A new field area_sqm is created, and the area of each parking lot is calculated 
using the expression $area. Filtering: Only parking lots large enough for economically 
viable solar canopy installations are selected. A filter is applied using an expression such 
as "area_sqm" > 17 (17 m²). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: A power grid layer obtained from OSM (power=line, power=substation) and 
merged into a single power_grid layer. 
Tool: "Distance to nearest hub (line to hub)" (Processing Toolbox -> Vector analysis -> 
Distance to nearest hub (line to hub)).    
Action: The distance from each parking lot to the nearest element of the power grid is 
calculated. 
Parking areas located between 20 m and 30 km from the nearest grid connection point 
were retained, ensuring both technical safety and cost-effective power connectivity. A 
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combined expression is used for this: "HubDist" >= 20 AND "HubDist" <= 30000. 
3. Verification: Verification of the collected data will be carried out in the following steps: 
cross-comparison of information from open sources to identify discrepancies in the 
spatial location and classification of objects; topological control (verification of the 
correctness of connections between lines and nodes of the network). 
Final result: Polygon layer Parking_Areas. 
 
2.4. Farms (solar and wind) 
 
These layers identify farm territories suitable for solar and wind installations. For the 
analysis of potential in agricultural areas, polygon layers of land use and buildings from 
the OpenStreetMap database were used. Farmlands are represented by two main land 
use layers and associated building layers. 
2.4.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Farm Areas landuse=farmyard The operational area of a farm with 

buildings.  
landuse=farmland Agricultural land used for cultivation. 

Agri. 
Buildings 

building=farm A farmhouse. 
 

building=farm_auxiliary An auxiliary farm building.  
building=barn A large storage building.  
building=cowshed A building for housing cows.  
building=greenhouse A greenhouse for growing plants. 

 
2.4.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer (Farms_Base) 
Importing Data from OSM: Tool: QuickOSM Plugin. 
Action: A query is executed to extract all polygonal features matching the tags 
landuse=farmyard and landuse=farmland, as well as polygonal and point features for 
building tags (building=farm, building=barn). 
Consolidation and Cleaning: 
Tool: "Merge vector layers" (Processing Toolbox -> Vector general -> Merge vector 
layers). 
Action: All resulting layers (land use and building polygons) are combined into a single 
layer. 
Tool: "Dissolve" (Vector -> Geoprocessing Tools -> Dissolve). 
Action: This is applied to merge adjacent or overlapping features, which helps define the 
boundaries of individual farm complexes. 
Tool: "Fix geometries" (Processing Toolbox -> Vector geometry -> Fix geometries). 
Action: Ensures the topological correctness of the layer. The result is saved as 
Farms_Base. 
2. Creating the farms_solar layer 
This process is applied to the Farms_Base layer to identify zones suitable for solar 
energy. 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon from the Global Solar Atlas 
raster. Features with "GHI_mean" >= 1100 are selected. 
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Area Analysis: Tool: "Field Calculator". 
Action: The area is calculated ($area). Small farms unsuitable for significant 
installations are filtered out ("area_sqm" > 100). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
Tool: "Distance to nearest hub". 
Action: The distance to the nearest grid element is calculated. A combined filter is 
applied: "HubDist" >= 20 AND "HubDist" <= 30000. 
Assessment of Potential for BESS/PCS Installation: 
Rationale: Farms that have passed the area filter are assumed to have sufficient open 
space to accommodate energy storage systems. This criterion is considered met for all 
selected features. 
3. Creating the farms_wind layer 
This process is also applied to the Farms_Base layer to identify zones suitable for wind 
energy. 
Analysis of Wind Speed (≥ 5.0 m/s at 100m height): 
Data Source: Average wind speed raster from the Global Wind Atlas. 
Tool: "Zonal Statistics".   
Action: The average wind speed is calculated for each polygon. Features with 
"wind_speed_mean" >= 5.0 are selected. 
Exclusion of Orographic Constraints (slopes > 15°): 
Data Source: Copernicus DEM. 
Tools: "Slope", "Raster Calculator", "Polygonize", "Intersection". 
Action: A vector layer of suitable slopes (≤ 15°) is created and then intersected with the 
farms layer to exclude areas on steep slopes. 
Analysis of Road Accessibility (≤ 5 km): 
Data Source: Layer of state and local roads from OSM. 
Tool: "Distance to nearest hub". 
Action: Farms located no more than 5 km from roads are selected. 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Action: The same methodology as for the solar layer is applied, using the filter "HubDist" 
>= 20 AND "HubDist" <= 30000. 
Application of Exclusion Buffer Zones (Overlay Analysis): 
Tool: "Buffer". 
Action: Buffer zones are created around infrastructure features: 60 meters around 
roads, 500 meters around railways, and 10 km around airports (aeroway=aerodrome). 
Tool: "Merge vector layers" and "Dissolve". 
Action: All buffer zones are combined into a single exclusion_zones layer. 
Tool: "Difference" (Vector -> Geoprocessing Tools -> Difference). 
Action: The exclusion_zones layer is "cut out" from the layer of potential farms to 
exclude areas where wind turbine construction is restricted. 
4. Verification 
Verification of the collected data will be carried out in the following steps: cross-
comparison of information from open sources to identify discrepancies in the spatial 
location and classification of objects; topological control (verification of the correctness 
of connections between lines and nodes of the network). 
Final Result: Two separate polygonal layers: farms_solar and farms_wind. 
 
2.5.  Waste_sites 
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This layer identifies solid waste landfills suitable for the installation of solar power 
plants. 
2.5.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Landfills landuse=landfill An area used for waste disposal. 

2.5.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer: Polygons with the landuse=landfill are downloaded using 
QuickOSM.  
2. Filtering by Technical Suitability Criteria  
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon in the Waste_Sites_Base 
layer. Features that satisfy the condition "GHI_mean" >= 1100 are selected. 
Area Analysis: 
Tool: "Field Calculator" 
Action: The area of each feature is calculated ($area). Small plots unsuitable for 
industrial-scale solar farms are filtered out ("area_sqm" > 100). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Tool: "Distance to nearest hub (line to hub)". 
Availability of substations: Including power=substation features in the analysis directly 
addresses the availability of substations within the specified distance. 
Action: The distance from each feature to the nearest element of the power grid is 
calculated. 
Filtering: Features that meet two conditions are selected: located no more than 30 km 
away and no less than 20 m away. A combined expression is used for this: "HubDist" >= 
20 AND "HubDist" <= 30000. 
3. Verification: Verification of the collected data will be carried out in the following steps: 
cross-comparison of information from open sources to identify discrepancies in the 
spatial location and classification of objects; topological control (verification of the 
correctness of connections between lines and nodes of the network). 
Final Result: A polygonal layer named Waste_sites, containing polygons of landfills and 
other waste management facilities that have passed all GIS-based filtering stages. 
 
2.6. Industrial Sites solar and Industrial Sites wind 
 
These layers identify industrial zones suitable for the installation of solar and wind 
facilities. Industrial areas were analyzed using the polygon layer landuse=industrial from 
the OpenStreetMap database, which includes land used for industrial purposes. This 
layer covers territories with main, auxiliary, and service buildings of industrial, mining, 
transport, and other enterprises, as well as their access roads, utility networks, 
administrative buildings, and related infrastructure. 
2.6.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Industrial Zones landuse=industrial A general-purpose industrial area. 
Industrial Objects man_made=works A factory or manufacturing complex.  

power=plant A power plant.  
building=factory A building used as a factory. 

2.6.2. Detailed Processing Methodology in QGIS 
1. Creating the Base Layer (Industrial_Base) 
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Importing Data from OSM: Tool: QuickOSM Plugin. 
Action: A query is executed to extract all polygonal and point features matching the tags 
in the table. 
Consolidation and Cleaning: 
Tool: "Merge vector layers" and "Dissolve". 
Action: All resulting polygons are merged into a single layer, and adjacent or overlapping 
features are dissolved. "Fix geometries" is applied to ensure topological correctness. 
The result is saved as Industrial_Base 
2 Creating the Industrial_Sites_solar layer 
This process is applied to the Industrial_Base layer to identify zones suitable for solar 
energy. 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon from the Global Solar Atlas 
raster. Features with "GHI_mean" >= 1100 are selected. 
Area Analysis: 
Tool: "Field Calculator". 
Action: The area is calculated ($area). Small plots unsuitable for industrial-scale solar 
farms are filtered out ("area_sqm" > 100). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
Tool: "Distance to nearest hub". 
Action: The distance to the nearest grid element is calculated. A combined filter is 
applied to select features located no less than 20 m and no more than 30 km away: 
"HubDist" >= 20 AND "HubDist" <= 30000. 
Assessment of Potential for BESS/PCS Installation: 
Rationale: Industrial zones that have passed the area filter are assumed to have 
sufficient open space to accommodate energy storage systems. This criterion is 
considered met for all selected features. 
3. Creating the Industrial_Sites_wind layer 
This process is also applied to the Industrial_Base layer to identify zones suitable for 
wind energy. 
Analysis of Wind Speed (≥ 5.0 m/s at 100m height): 
Data Source: Average wind speed raster from the Global Wind Atlas. 
Tool: "Zonal Statistics". 
Action: The average wind speed is calculated for each polygon. Features with 
"wind_speed_mean" >= 5.0 are selected. 
Area Analysis for Wind Turbines: Tool: "Field Calculator". 
The minimum viable area for wind turbine installation is set to 1.7 ha (17,000 m²). All 
smaller plots were excluded using the Field Calculator expression "area_sqm" > 17000. 
Filtering: A filter is applied using the expression "area_sqm" > 17000 (1,7 ha = 17,000 
m²). 
Exclusion of Orographic Constraints (slopes > 15°): 
Data Source: Copernicus DEM. 
Tools: "Slope", "Raster Calculator", "Polygonize", "Intersection". 
Action: A vector layer of suitable slopes (≤ 15°) is created and then intersected with the 
industrial zones layer to exclude areas on steep slopes. 
Analysis of Road Accessibility (≤ 5 km): 
Data Source: Layer of state and local roads from OSM. 
Tool: "Distance to nearest hub". 
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Action: Industrial zones located no more than 5 km from roads are selected. 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Action: The same methodology as for the solar layer is applied, using the filter "HubDist" 
>= 20 AND "HubDist" <= 30000. 
Application of Exclusion Buffer Zones (Overlay Analysis): 
Tool: "Buffer". 
Action: Buffer zones are created around infrastructure features: 60 meters around 
roads, 500 meters around railways, and 10 km around airports (aeroway=aerodrome). 
Tool: "Merge vector layers" and "Dissolve". 
Action: All buffer zones are combined into a single exclusion_zones layer. 
Tool: "Difference" (Vector -> Geoprocessing Tools -> Difference). 
Action: The exclusion_zones layer is "cut out" from the layer of potential industrial zones 
to exclude areas where wind turbine construction is restricted. 
4. Verification: Verification of the collected data will be carried out in the following steps: 
cross-comparison of information from open sources to identify discrepancies in the 
spatial location and classification of objects; topological control (verification of the 
correctness of connections between lines and nodes of the network). 
Final result: Two layers - Industrial_Sites_Solar and Industrial_Sites_Wind. 
 
2.7. Mines_and_quarries 
 
This layer identifies post-mining sites suitable for the installation of solar power plants. 
For the analysis of exhausted mining areas, specialized layers from the OpenStreetMap 
database were used, representing quarries, mines, and spoil heaps. 
2.7.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Quarries & 
Mines 

landuse=quarry An open-pit mine. 
 

landuse=mine An area related to mineral extraction. 
Spoil Heaps man_made=spoil_heap A pile of waste rock from mining 

operations. 
2.7.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer (Mines_Quarries_Base) 
Importing Data from OSM: Tool: QuickOSM Plugin. 
Action: A query is executed to extract all polygonal features matching the tags listed in 
the table (landuse=quarry, landuse=mine, man_made=spoil_heap, and their 
disused/abandoned variations). This ensures a comprehensive dataset of areas 
impacted by mining activities. 
Consolidation and Cleaning: 
Tool: "Merge vector layers" (Processing Toolbox -> Vector general -> Merge vector 
layers). 
Action: All retrieved layers are combined into a single layer. 
Tool: "Dissolve" (Vector -> Geoprocessing Tools -> Dissolve). 
Action: This is applied to merge adjacent or overlapping features (a quarry and its 
associated spoil heap) into single, contiguous zones. 
Tool: "Fix geometries" (Processing Toolbox -> Vector geometry -> Fix geometries). 
Action: Ensures the topological correctness of the layer for subsequent analysis. The 
result is saved as Mines_Quarries_Base. 
2 Filtering by Technical Suitability Criteria 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
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Data Source: GHI raster layer from the Global Solar Atlas. 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon. Features that satisfy the 
condition "GHI_mean" >= 1100 are selected. 
Area Analysis: 
Tool: "Field Calculator". 
Action: The area of each feature is calculated ($area). Small plots unsuitable for 
industrial-scale solar farms are filtered out ("area_sqm" > 10) 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
Tool: "Distance to nearest hub". 
Action and Rationale: Including substations (power=substation) in the analysis directly 
addresses the criterion of substation availability. The distance to any grid element 
serves as a proxy for the feasibility of laying cables. 
Filtering: A combined expression is used to select features located no less than 20 m 
(safety buffer) and no more than 30 km (economic viability) away: "HubDist" >= 20 AND 
"HubDist" <= 30000. 
Availability to install BESS/PCS: Sites that have passed the area filter (> 100м2) are, by 
definition, large enough to accommodate energy storage systems. This criterion is 
considered met for all selected territories. 
Stage 3: Verification 
Verification of the collected data will be carried out in the following steps: cross-
comparison of information from open sources to identify discrepancies in the spatial 
location and classification of objects; topological control (verification of the correctness 
of connections between lines and nodes of the network). 
Final Result: A polygonal layer named Mines_and_quarries, containing polygons of post-
mining sites that have passed all GIS-based filtering stages. 
 
2.7. Artificial_Inland_Water_Bodies 
 
This layer identifies artificial water bodies suitable for the installation of floating solar 
power plants. 
2.7.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Artificial Water Bodies water=reservoir A water reservoir.  

landuse=reservoir The area of a reservoir.  
landuse=basin A technical basin or settling pond. 

2.7.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer (Artificial_Water_Base) 
Importing Data from OSM: 
Tool: QuickOSM Plugin. 
Action: A query is executed to extract all polygonal and linear features matching the tags 
listed in the table. 
Tool: "Difference" (Vector -> Geoprocessing Tools -> Difference). 
Action: To ensure the exclusion of natural water bodies, features tagged as natural 
(downloaded via a natural=water query from OSM) are "cut out" from the 
All_Water_Bodies layer. This is a critical step to avoid conflicts with water fund 
protection criteria. 
Final Cleaning: 
Tool: "Dissolve" (Vector -> Geoprocessing Tools -> Dissolve). 
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Action: Applied to merge adjacent or overlapping features. 
Tool: "Fix geometries". 
Action: Ensures the topological correctness of the layer. The result is saved as 
Artificial_Water_Base. 
2. Filtering by Technical Suitability Criteria 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon from the Global Solar Atlas 
raster. Features with "GHI_mean" >= 1100 are selected. 
Area Analysis: 
 
Tool: "Field Calculator". 
Action: The area of each water body is calculated ($area). Small features unsuitable for 
economically viable projects are filtered out ("area_sqm" > 100). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
Tool: "Distance to nearest hub". 
Action: The distance to the nearest grid element is calculated. A combined filter is 
applied to select features located no less than 20 m and no more than 30 km away: 
"HubDist" >= 20 AND "HubDist" <= 30000. 
Availability to install BESS/PCS: Floating solar farms require land-based infrastructure 
for inverters, transformers, and grid connection. It is assumed that the shoreline area of 
water bodies that have passed the area filter provides sufficient space for BESS/PCS 
installation. This criterion is considered met from a spatial availability perspective. 
3. Verification 
Verification of the collected data will be carried out in the following steps: cross-
comparison of information from open sources to identify discrepancies in the spatial 
location and classification of objects; topological control (verification of the correctness 
of connections between lines and nodes of the network). 
Final Result: A polygonal layer named Artificial_Inland_Water_Bodies, containing 
polygons of artificial water bodies that have passed all GIS-based filtering stages. 
 
2.9. Urban_Wastewater_Treatment_Sites 
 
This layer identifies wastewater treatment plant sites suitable for the installation of solar 
panels. 
2.9.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Treatment 
Plants 

man_made=wastewater_plant A wastewater treatment station. 

 landuse=industrial + 
industrial=wastewater_treatment 

Land used for industrial 
purposes, specifically dedicated 
to wastewater treatment 
activities. 
Includes treatment facilities, 
technical buildings, and 
associated infrastructure used 
for the purification and 
management of municipal or 
industrial sewage. 
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 man_made=storage_tank / 
natural=water + wastewater=pond 

Artificial or natural tanks and 
ponds used for storing 
untreated or treated 
wastewater. 
These areas can include 
lagoons, stabilization ponds, or 
reservoirs within wastewater 
treatment systems. 

 landuse=basin + basin=settling / 
wastewater=pond 

Basins or sedimentation ponds 
designed for mechanical or 
biological wastewater 
treatment. 
Used to settle suspended solids, 
remove impurities, or 
biologically purify wastewater 
before discharge or reuse.  

 man_made=pumping_station A facility equipped with pumps 
for transferring wastewater 
between different stages of the 
treatment process or lifting it to 
higher elevations within the 
sewage network. 

2.9.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer (Wastewater_Base) 
Importing Data from OSM: 
Tool: QuickOSM Plugin. 
Action: A query is executed to extract all features (polygons and points) matching the 
tag man_made=wastewater_plant.  
Tool: "Dissolve" (Vector -> Geoprocessing Tools -> Dissolve). 
Action: Applied to merge adjacent or overlapping features. 
Tool: "Fix geometries" (Processing Toolbox -> Vector geometry -> Fix geometries). 
Action: Ensures the topological correctness of the layer. The result is saved as 
Wastewater_Base. 
2. Filtering by Technical Suitability Criteria  
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon from the Global Solar Atlas 
raster. Features with "GHI_mean" >= 1100 are selected. 
Area Analysis: 
Tool: "Field Calculator". 
Action: The area of each feature is calculated ($area). Small plots unsuitable for 
industrial-scale solar farms are filtered out (   "area_sqm" > 100). 
Analysis of Road Accessibility: 
Data Source: Layer of roads (regional and district) from OSM. 
Tool: "Distance to nearest hub". 
Action: The presence of roads in the immediate vicinity is checked. Given that treatment 
plants typically have access roads, this criterion is considered met for most sites, but a 
filter can be applied to remove anomalously remote plots (distance to road ≤ 5 km). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
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Tool: "Distance to nearest hub". 
Action: The distance to the nearest grid element is calculated. A combined filter is 
applied: "HubDist" >= 20 AND "HubDist" <= 30000. 
Assessment of Potential for BESS/PCS Installation: 
Wastewater treatment plants that have passed the area filter are assumed to have 
sufficient open space (on the roofs of technical buildings or on open ground) to 
accommodate energy storage systems. This criterion is considered met for all selected 
features. 
3. Verification 
Verification of the collected data will be carried out in the following steps: cross-
comparison of information from open sources to identify discrepancies in the spatial 
location and classification of objects; topological control (verification of the correctness 
of connections between lines and nodes of the network). 
Final Result: A polygonal layer named Urban_Wastewater_Treatment_Sites, containing 
polygons of wastewater treatment plants that have passed all GIS-based filtering 
stages. 
 
2.10. Degraded Land not usable for Agriculture solar 
 
This layer identifies degraded and low-productivity lands suitable for solar and wind 
installations. 
2.10.1. Data sources from OpenStreetMap (OSM): 

Category OSM (key=value) Description 
Naturally 
Degraded 

natural=heath Low-growing woody vegetation, often dominated 
by heather or similar shrubs, typically found on 
nutrient-poor, acidic soils — these are wastelands 
where almost nothing grows, characterized by 
poor, dry, and infertile soils with sparse low 
vegetation  

natural=bare_rock Exposed rock outcrops.  
natural=scree Slopes covered with rock fragments.  
natural=sand Sandy areas. 

2.10.2. Detailed Processing Methodology in QGIS: 
1. Creating the Base Layer (Degraded_Lands_Base) 
Importing Component Data from OSM: 
Tool: QuickOSM Plugin. 
Action: Several queries are executed to extract all polygonal features corresponding to 
each of the categories listed in the table.  
Consolidation and Creation of a Single Composite Layer: 
Tool: "Merge vector layers" (Processing Toolbox -> Vector general -> Merge vector 
layers). 
Action: All the retrieved component layers are combined into a single layer representing 
the union of all types of degraded lands. 
Tool: "Dissolve" (Vector -> Geoprocessing Tools -> Dissolve). 
Action: This is applied to merge adjacent or overlapping polygons into single, contiguous 
zones of degraded land. 
Tool: "Fix geometries" (Processing Toolbox -> Vector geometry -> Fix geometries). 
Action: Ensures the topological correctness of the layer. The result is saved as 
Degraded_Lands_Base. 
2. Creating the Degraded_Land_Not_Usable_for_Agriculture_solar layer 
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This process is applied to the Degraded_Lands_Base layer to identify zones suitable for 
solar energy. 
Analysis of Global Horizontal Irradiation (GHI ≥ 1100 kWh/m²): 
Tool: "Zonal Statistics". 
Action: The average GHI value is calculated for each polygon from the Global Solar Atlas 
raster. Features with "GHI_mean" >= 1100 are selected. 
Area Analysis: 
Tool: "Field Calculator". 
Action: The area is calculated ($area). Small plots unsuitable for industrial-scale solar 
farms are filtered out ("area_sqm" > 100). 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Data Source: power_grid layer (merged power=line and power=substation from OSM). 
Tool: "Distance to nearest hub". 
Action: The distance to the nearest grid element is calculated. A combined filter is 
applied: "HubDist" >= 20 AND "HubDist" <= 30000. 
3. Creating the Degraded_Land_Not_Usable_for_Agriculture_wind layer 
This process is also applied to the Degraded_Lands_Base layer to identify zones suitable 
for wind energy. 
Analysis of Wind Speed (≥ 5.0 m/s at 100m height): 
Data Source: Average wind speed raster from the Global Wind Atlas. 
Tool: "Zonal Statistics". 
Action: The average wind speed is calculated for each polygon. Features with 
"wind_speed_mean" >= 5.0 are selected. 
Area Analysis for Wind Turbines: 
Tool: "Field Calculator". 
Action: The area is calculated ($area). Plots with an area less than 1,7 ha are filtered out 
using the expression "area_sqm" > 17000. 
Exclusion of Orographic Constraints (slopes > 15°): 
Data Source: Copernicus DEM. 
Tools: "Slope", "Raster Calculator", "Polygonize", "Intersection". 
Action: A vector layer of suitable slopes (≤ 15°) is created and then intersected with the 
degraded lands layer. 
Analysis of Road Accessibility (≤ 5 km): 
Data Source: Layer of state and local roads from OSM. 
Tool: "Distance to nearest hub". 
Action: Zones located no more than 5 km from roads are selected. 
Analysis of Grid Connection Point Availability (from 20 m to 30 km): 
Action: The same methodology as for the solar layer is applied, using the filter "HubDist" 
>= 20 AND "HubDist" <= 30000. 
Application of Exclusion Buffer Zones (Overlay Analysis): 
Tools: "Buffer", "Merge vector layers", "Dissolve", "Difference". 
Action: Buffers are created (60 m around roads, 500 m around railways, 10 km around 
airports), merged into a single exclusion_zones layer, and "cut out" from the layer of 
potential sites. 
4. Verification 
Verification of the collected data will be carried out in the following steps: cross-
comparison of information from open sources to identify discrepancies in the spatial 
location and classification of objects; topological control (verification of the correctness 
of connections between lines and nodes of the network). 
Final Result: Two separate polygonal layers: 
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Degraded_Land_Not_Usable_for_Agriculture_solar and 
Degraded_Land_Not_Usable_for_Agriculture_wind. 
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