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INTRODUCTION 
The Energy Community Secretariat, with assistance from the European Climate 
Foundation (ECF) under its Ukraine Programme, is implementing a project aimed at 
establishing Cross-Border Renewable Energy Acceleration Areas (RAAs) in Ukraine. 

This initiative targets five critical regions - Lvivska, Zakarpatska, Ivano-Frankivska, 
Chernivetska and Vinnytska Oblasts, chosen for their strategic positioning along 
Ukraine's borders with the EU and Moldova and their environmental significance. 
These oblasts encompass protected natural areas and substantial renewable 
energy potential, serving as a focal point for advancing Ukraine's green recovery, 
energy transition, and integration into the EU energy market.  

This Report represents the results of the implementation of the GIS maps for 
potential REAAs, including explanatory notes on data sources and methodologies.  

The Report is structured in three chapters:  

- Chapter 1 of the Report describes the database used for mapping purposes. 
- Chapter 2 presents the criteria on renewable energy potential and 

infrastructure readiness, detailing the methodological basis for developing 
the corresponding criteria groups, their structure across the defined clusters 
(zones), and the key steps applied to generate thematic maps based on 
these criteria. 

- Chapter 3 describes geodata package for the purposes of online publication. 
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1. MAPPING INFORMATION BASE 

1.1. Structure of the database for mapping purpose 

The database contains feature classes representing the input and output datasets 
used for assessing renewable energy potential and infrastructure readiness within 
the identified clusters for the purposes of RAAs designation. 

Name of database: Energy.gpkg 

Format: GeoPackage 

List of database classes: 

Name Type Description 

Rooftops and Facades of 
Buildings polygon 

State-owned, municipal buildings 
(schools, hospitals, offices, factories, 
warehouses, commercial centres, 
residential complexes) suitable for 
solar PV installation on rooftops and 
facades, with sufficient structural 
capacity, surface area, irradiation and 
grid connection. 

Transport Infrastructure 
Corridor polygon 

Right-of-way land outside settlements 
and noise barriers/canopies within 
settlements along roads of state 
importance, suitable for installing 
horizontal or vertical solar PV panels 
where space, irradiation and grid 
access allow. 

Parking Areas polygon 

Road service facilities, including 
designated stopping places and 
parking lots, where canopy or ground-
mounted solar PV can be installed 
with adequate area, irradiation and 
access to medium-voltage grid 
infrastructure. 

Farms solar energy polygon 

Individual farmsteads outside 
settlements with roofs and facades 
suitable for solar PV, meeting 
irradiation, structural load, available 
area and proximity to medium/high-
voltage grid and substations. 

Farms wind energy polygon 

Farm areas meeting minimum 
average annual wind speed, slope, 
accessibility by public roads, and 
proximity to grid connection points, 
suitable for siting wind turbines and 
associated infrastructure. 
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Name Type Description 

Waste sites polygon 

Engineered municipal solid waste 
landfills and similar sites on non-
agricultural, deteriorated land suitable 
for ground-mounted solar PV, with 
sufficient area, irradiation and 
connection to medium/high-voltage 
grid. 

Industrial sites solar 
energy polygon 

Active, underused or abandoned 
industrial lands (including industrial 
parks) suitable for solar PV 
deployment, with adequate open 
area, irradiation and existing or 
planned medium/high-voltage lines 
and substations. 

Mines and quarries polygon 

Inactive, phase-out or partially active 
mines, mine waste heaps and 
quarries, including sites under just 
transition or rehabilitation plans, 
suitable for solar PV where irradiation, 
space and grid access are sufficient. 

Industrial sites wind 
energy polygon 

Industrial areas that satisfy wind 
speed, slope, accessibility and grid 
proximity criteria, suitable for 
installation of wind turbines and 
related infrastructure at industrial 
scale. 

Artificial Inland Water 
Bodies polygon 

Artificial reservoirs, ponds and canals 
(excluding irrigation and drainage 
canals) with sufficient water surface 
area, irradiation and nearby grid 
infrastructure for floating or bank-
mounted solar PV. 

Urban Wastewater 
Treatment Sites polygon 

Settlement and local wastewater 
treatment facilities with available 
area, sufficient irradiation, road 
access and nearby medium/high-
voltage grid for installing solar PV and 
associated BESS/PCS. 

Degraded Land Not 
Usable for Agriculture 
solar energy 

polygon 

Degraded and low-productive lands 
with disturbed surfaces or eroded, 
waterlogged, saline or contaminated 
soils, unsuitable for agriculture but 
suitable for solar PV where irradiation, 
area and grid connection conditions 
are met. 
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1.2. Lists of attributes for database classes 

Сlass Name Type Attribute Description 

Rooftops and Facades 
of Buildings 
Transport Infrastructure 
Corridor 
Parking Areas 
Farms solar energy 
Farms wind energy 
Waste sites 
Industrial sites solar 
energy 
Mines and quarries 
Industrial sites wind 
energy 
Artificial Inland Water 
Bodies 
Urban Wastewater 
Treatment Sites 
Degraded Land Not 
Usable for Agriculture 
solar energy 

Text Name Layer Name 

Double Area Area (m2) 

 
 
2. DESCRIPTION OF THE RENEWABLE ENERGY POTENTIAL AND 

INFRASTRUCTURE READINESS MAPS SET 
 

2.1. List of thematic maps 

To present the results of the analysis for each of the renewable energy potential and 
infrastructure readiness criteria groups, the following thematic maps were created: 
Areas protected under international legislation. 

A. Maps reflecting RE potential and infrastructure readiness criteria groups for Lviv 
Oblast  

1. Rooftops and Facades of Buildings: map of buildings potentially suitable for 
solar PV installation based on structural, spatial and grid-related criteria. 

2. Transport Infrastructure Corridor: map of right-of-way areas and noise 
barriers/canopies along state-importance roads suitable for horizontal or 
vertical PV installations. 

3. Parking Areas: map of road service facilities and parking lots potentially 
suitable for solar canopy deployment. 

4. Farms (Solar and Wind Energy): map of farmsteads suitable for mounted 
photovoltaic and wind systems 
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5. Industrial Sites (Solar and Wind Energy): map of operational, underused, or 
abandoned industrial zones that meet the technical and environmental 
criteria for deploying renewable energy technologies, including ground-
mounted or rooftop solar installations and wind turbines with their 
associated infrastructure. 

6. Artificial Inland Water Bodies: map of artificial reservoirs, ponds and canals 
appropriate for floating or shoreline solar installations. 

7. Degraded Land Not Usable for Agriculture: map of degraded or low-
productive lands suitable for PV installations. 

B. Maps of renewable energy resource potential 
Solar energy potential 

8. Global Horizontal Irradiation – Lviv Oblast 
9. Global Horizontal Irradiation – Ivano-Frankivska Oblast 
10. Global Horizontal Irradiation – Chernivetska Oblast 
11. Global Horizontal Irradiation – Zakarpatska Oblast 
12. lobal Horizontal Irradiation – Vinnytska Oblas 
13. Global Horizontal Irradiation – Integrated map for all 5 Oblasts 

Wind energy potential 
14. Wind Speed at a Height of 100 m – Lviv Oblast 
15. Wind Speed at a Height of 100 m – Ivano-Frankivska Oblast 
16. Wind Speed at a Height of 100 m – Chernivetska Oblast 
17. Wind Speed at a Height of 100 m – Zakarpatska Oblast 
18. Wind Speed at a Height of 100 m – Vinnytska Oblast 
19. Wind Speed at a Height of 100 m – Integrated map for all 5 Oblasts 

C. Maps of electricity grid connection potential 
20. Grid Connection Potential – Lviv Oblast 
21. Grid Connection Potential – Ivano-Frankivska Oblast 
22. Grid Connection Potential – Chernivetska Oblast 
23. Grid Connection Potential – Vinnytska Oblast 
24. Grid Connection Potential – Zakarpatska Oblast 

 
2.2. Mathematical basis for a map creation 

The maps were created in the open source QGIS software. To create map layouts, 
digital maps were created, on the basis of which printing layouts were formed. 

The mathematical basis for creating maps consists of choosing a coordinate 
system, scale and map layout. 

The Web Pseudo-Mercator coordinate system (EPSG:3857) based on the WGS 84 
datum was chosen as the coordinate system. This choice was due to several 
factors: 

1. Reducing certain visual distortions of the territory in the coordinate system WGS 
84. 
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2. Compatibility with web publication. 
3. Speed of processing base map data. 

The original data was not converted and remained in the coordinate system WGS 
84. 

The scale of the maps for printing was chosen taking into account the standard 
sizes of A3 paper sheets -1:2 500 000 

The layout orientation was chosen in landscape format due to the configuration of 
the study area. 

2.3. Thematic basis for map creation 

Thematic maps were created based on a combination of thematic layers that were 
collected in the database. 

A base topographic map of the world was used as the base. 

The basic order of layer organization: 

• bottom layer - base topographic map; 
• upper layers - thematic polygonal layers.  

Main elements of thematic content: 

• map name – placed in the middle of the map; 
• map legend – located in the lower left corner; the legend contains 

conventional designations of the thematic content of the map, namely 
graphic symbols for displaying thematic layers. 

The colour scheme for colouring objects was selected based on the Protocol on GIS 
in the REAA project. 

2.4. Basic steps for creating printed thematic maps 
 
1. Start a New QGIS Project. 

Launch QGIS: Open QGIS Desktop. It will start a new blank project by default. (If a 
project is already open, we can create a new one via Project > New). 

Save QGIS project with Project > Save As to avoid losing work. QGIS project files 
(.qgz) store layer references, styles, etc., which is helpful if need to revisit the map 
design later. 

Load the data: Add GeoPackage vector layers to the project. Click Layer > Add Layer 
> Add Vector Layer, choose .gpkg file, and select the relevant layers to import (it 
possible also drag and drop the GeoPackage from the Browser panel). 

2. Add a Topographic Base Map and GeoPackage Layers. 

QGIS doesn’t include detailed base maps by default, but we can add one via web 
services or plugins. A simple method is to install the QuickMapServices plugin (go 
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to Plugins > Manage and Install Plugins, search for "QuickMapServices", and install 
it). 

After the base map is in place, make sure that thematic data layers (the GeoPackage 
vectors) are added. They should draw on top of the base map. If not, reorder them 
in the Layers panel (drag layers so the base map is at the bottom). At this stage, 
each layer will have a random default color/symbol. Next, you’ll customize their 
styling. 

3. Style the Thematic Layers. 

Open Layer Properties: To adjust a layer’s appearance, open its Layer Properties 
window. Double-clicking the layer name or right-clicking and selecting Properties…, 
then go to the Symbology tab. 

Choose symbol and color: In the Symbology tab, we will see options depending on 
the layer geometry (point, line, or polygon). For polygon layers, we can set a Fill color 
and an Outline (Stroke) color/width. 

 
4. Create a Print Layout. 

The Print Layout allows to arrange the map and other map elements on a page for 
export. 

In QGIS main window, go to Project > New Print Layout…. When prompted, give the 
layout a name (e.g., "Final Map Layout") and click OK. A new layout window will open, 
showing a blank page. 

Go to Layout > Page Properties on the top menu. In the Item Properties panel on the 
right, set the page Size A3 and landscape Orientation. Add the map canvas to the 
layout: Click the Add Map button. Upon releasing the mouse, the current QGIS map 
view will appear in that frame on the layout. 
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5. Design the Layout. 

In QGIS Print Layout, we can insert various items via the toolbar or the Add Item 
menu. After adding each item, we can fine-tune its appearance in the Item Properties 
panel.  

To add the legend, click the Add Legend tool, then click on the layout where you want 
the legend to appear. The legend reflects layer names and styles (colors/symbols) 
as set in the Layers panel. 

 
 
6. Export the Final Map to a Print-Ready Format. 
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QGIS supports exporting to PDF (vector) and image formats like TIFF, PNG, JPEG at 
chosen resolutions. 

Export as PDF (vector): This is recommended for many academic purposes because 
PDF will preserve vector graphics (your linework, text, and vector shapes stay crisp 
at any scale). In the Layout window, click Layout > Export as PDF (or the PDF icon 
on the toolbar). Choose a save location and file name, then confirm. QGIS will 
generate a PDF of your layout. y default, text is embedded and vectors retained, so 
the PDF can be zoomed or printed high-res without quality loss.  
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Export as Image (TIFF/JPEG): If a high-resolution image file is required. Use Layout 
> Export as Image. In the dialog, choose TIFF (or JPEG) and enter the resolution 300 
DPI for print.  

 
 

3. GEODATA PACKAGE FOR THE PURPOSES OF ONLINE 
PUBLICATION 

Publishing to the web is done using the qgis2web plugin, which allows you to get a 
web page project with an interactive map. It replicates as many aspects of the 
project as it can, including layers, extent and styles (including categorized and 
graduated). No server-side software required. 

Latest stable version: 3.30.0 



 

13 
Implemented by the Energy Community Secretariat 

 
Before starting work, project settings were made: 

• Set project title, abstract, background and highlight colours in 
Project > Properties... > General/Metadata. 

• Give layers correct names in Layers Panel. 
• Give layer columns correct names via Layer > Properties > Attributes 

Form > Fields > Alias. 
• Hide fields which don't appear in popups by changing their Widget 

Type to "Hidden". 

 

Plugin settings: 

• Leaflet library was selected as the publishing method. 
• Visibility was selected for layers and fields during publishing. 
• Attribute display method: inline label - always visible (displays field name on 

the same line as data) 
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• Header placement: upper left 
• Abstract: lower right 
• Layers list: Collapsed 
• Measure tool: Metric 
• Address search: OSM 
• Template: full-screen 
• Extent: Canvas extent 
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On the export tab, select the folder to store the web map. 

In the settings, you can change the number of objects visible during preview. The 
default is 1000 objects. 

After clicking the export button, a web map is generated. The map creation process 
is displayed in the form of a progress window. 
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The finished map is checked. The name of the folder with the files is renamed 
according to the name of the map. 
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